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Interfacing a DSP With the Real World

digital digital
inputs outputs

analog
output

analog
input

digital inputs = 4 DIP switches
digital outputs = 4 LEDs
ADC and DAC = AIC23 codec



DIP Switches and LEDs

LED and DIP switch interface functions are provided in dsk6713bsl.lib.

Initialize the DSK with the BSL function DSK6713 init();

Initialize DIP/LEDs with
DSK6713_DIP_init() and/or DSK6713_LED _init()

Read state of DIP switches with
DSK6713 DIP_get(n)

Change state of LEDs with
DSK6713 LED_on(n) or
DSK6713 LED_off(n) or
DSK6713 LED_toggle(n)

where n=0, 1, 2, or 3.

Documentation is available in Board Support Library API (on course
website).
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AlC23 Codec

AlC23 codec performs both ADC and DAC functions
Stereo input and output (left+right channels)

Initialization steps:
Initialize the DSK with the BSL function DSK6713 init();

Open the codec with the BSL function
hCodec = DSK6713 AIC23 openCodec(0,&config);

o “hCodec” is the codec “handle”. You can think of this as a unique
address of the codec on the McBSP bus.

o “config” is the default configuration of the codec. See the header
file dsk6713 aic23.h and the AlIC23 codec datasheet (link on the

course web page) for details.
Optional: Set the codec sampling frequency.

Configure the McBSP to transmit/receive 32 bits (two 16 bit
samples) with the CSL function McBSP_FSETS()

Set up and enable interrupts

oWTECy,
< 1,
& a0
[ >
@ B 1]



Codec Initialization Example (from Kehtarnavaz)

Initialize the DSK

Open the codec with
the default
configuration.

Configure multi-
channel buffered
serial port (McBSP)

SPCR = serial port
control register

RCR = receive control
register

XCR = transmit control
register

See SPRU508e.pdf
Set the sampling rate

Configure and enable
interrupts

Do normal processing
(we just enter a loop
here)

interrupt void serialPortRcvISR(void); // ISR function prototype

void main()

{

DSK6713_init(); // Initialize the board support library, must be called first
hCodec = DSK6713_AIC23_openCodec(d, &config); // Open the codec

// Configure buffered serial ports for 32 bit operation

// This allows transfer of both right and left channels in one read/write
MCBSP_FSETS(SPCR1, RINTM, FRM);

MCBSP_FSETS(SPCR1, XINTM, FRM);

MCBSP_FSETS(RCR1, RWDLEN1, 32BIT);

MCBSP_FSETS(XCR1, XWDLEN1, 32BIT);

DSK6713_AIC23_setFreq(hCodec, DSK6713_AIC23_FREQ_48KHZ); // set the sampling rate

// Interrupt setup

IRQ_globalDisable(); // Globally disables interrupts
IRQ_nmiEnable(); // Enables the NMI interrupt
IRQ_map(IRQ_EVT_RINT1,15); // Maps an event to a physical interrupt
IRQ_enable(IRQ_EVT_RINT1); // Enables the event

IRQ_globalEnable(); // Globally enables interrupts

while(1)
{
s




AlIC23 Codec: Interrupts

We will use an between the DSP
and the codec.

DSP can do useful things while waiting for samples to
arrive from codec, e.g. check DIP switches, toggle LEDs

C6x interrupt basics:

Interrupt sources must be mapped to interrupt events
o 16 physical “interrupt sources” (timers, serial ports, codec, ...)
o 12 logical “interrupt events” (INT4 to INT15)

Interrupt events have associated “interrupt vectors”. An
“interrupt vector” is a special pointer to the start of the
“interrupt service routine” (ISR).

Interrupt vectors must be set up in your code (usually in the
file “vectors.asm”).

You are also responsible for writing the ISR.



Interrupts

main code

physical interrupt source X
linked to
logical interrupt event N

interrupts enabled

interrupt event N occurs
(state is
automatically saved)
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interrupt vector N

branch to interrupt service routine

interrupt service routine

do something useful

make sure the ISR completes
before the next interrupt occurs

return to main code



Interrupt Vector

e We usually link the physical codec interrupt to INT15.

e The ISR in this example is called “serialPortRcvISR” (you
can rename it if you like).

e C function “x” is called “_x” in ASM files.

e The interrupt vector is usually in the vectors.asm file:

e Each interrupt vector must be exactly 8 ASM instructions

150, INT1S:
MVKL .S2 _serialPortRcvISR, BO
MVKH .SZ2 _serialPortRcvISR, B@
B .S2 BO
NOP

NOP
NOP
NOP
NOP




A Simple Interrupt Service Routine

49| interrupt void serialPortRcvISR()

Uint32Z temp;

temp = MCBSP_read(DSK6713_AICZ23_DATAHANDLE); // read L+R channels
MCBSP_write(DSK6713_AIC23_DATAHANDLE,temp); // write L+R channels

Remarks:

e \VICBSP read() requests L+R samples from the codec’s ADC

e \VICBSP write() sends L+R samples to the codec’s DAC

e This ISR simply reads in samples and then sends them back out.



Setting the Codec Sampling Frequency

Here we open the codec with the default configuration:
hCodec = DSK6713_AIC23_openCodec(®, &config); // Open the codec

The structure “config” is declared in dsk6713 aic23.h

Rather than editing the default configuration in the header file, we can change
the sampling frequency after the initial configuration:

DSK6713_AIC23_setFreq(hCodec, DSK6713_AIC23_FREQ - // set the sampling rate

Frequency definitions are in dsk6713 aic.h

/% Frequency Definitions */

#define DSK6713_AICZ3_FRE(Q_GSKHZ

#define DSKb713_AICZ3_FREQ_16KHZ

#define DSK671353_AICZ3_FREQ Z24KHZ

#define DEK6713_AICZ3_FREQ_3Z2KHZ This is actually
#define DSK6713_AICZ23_FREQ_44KHZ 44. 1kHz
#define DSK6713_AICZ3_FREQ_48KHZ ’

#define DEK671353_AICZ3_FREQ_Y96KHZ




Other Codec Configuration
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Line input volume level (individually controllable for left
and right channels)

Headphone output volume level (individually
controllable for left and right channels)

Digital word size (16, 20, 24, or 32 bit)
Other settings, e.g. byte order, etc. For more details,
see:

dsk6713_aic23.h

AlC23 codec datasheet (link on course web page)



Codec Data Format and How To Separate
the Left/Right Channels

// we can use the union construct in C to have
// the same memory referenced by two different variables
union {Uint32 combo; short channel[2];} temp;

temp.channel[0] (short) temp.channel[1] (short)

“— temp.combo (Uint32)

// the McBSP functions require that we

// read/write data to/from the Uint32 variable

temp.combo = MCBSP_read(DSK6713_AIC23 DATAHANDLE);
MCBSP_write(DSK6713_AIC23_DATAHANDLE, temp.combo);

// but if we want to access the left/right channels individually
// we can do this through the short variables

Leftchannel = temp.channel[1];

Rightchannel = temp.channel[0];
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Final Remarks on DSP/Codec Interface
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In most real-time DSP applications, you process
samples as they become available from the codec’s
ADC (sample-by-sample operation).
This means that

MCBSP_read()

--- processing here ---

MCBSP_write()
The ISR must run in real-time, i.e. the total execution
time must be less than one sampling period.

You can do other tasks, e.g. DIP/LED processing,
outside of the ISR (in your main code).



C6713 DSK Memory Architecture

TSM320C6713 DSP chip has 256kB internal SRAM
Up to 64kB of this SRAM can be configured as shared L2 cache

DSK provides additional 16MB external RAM (SDRAM)
DSK also provides 512kB external FLASH memory

Code location (.text in linker command file)
internal SRAM memory (fast)

external SDRAM memory (typically 2-4x slower, depends on cache
configuration)

Data location (.data in linker command file)
internal SRAM memory (fast)

external SDRAM memory (slower, depends on datatypes and cache
configuration)
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TMS320C6713 DSK Memory Map

OOOO OOOO L2 Memory Block Base Address
Internal SRAM (256kB)
0003 FFFF

0x0000 0000

your code+data here

192K-Byte RAM

8000 0000

External SDRAM (16 MB)

8FFF FFFF
0x0003 0000
F LAS H 0x0003 4000
16K-Byte RAM
16K-Byte RAM
0x0003 FFFF

FFFF FFFF
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Linker Command File Example (part 1)

--diag_suppress=16002

MEMORY
{
VECS 0 = Ox00000000 1 = Ox00000200 /* interrupt vectors */
IRAM O = 0x00000200 1 = Ox0002FEQGO /* 192kB - Internal RAM */
L2RAM O = Ox00030000 1 = Ox00010000 /* 64kB - Internal RAM/CACHE */
EMIFCEO o = Ox80000000 1 = 0x10000000 /* SDRAM in 6713 DSK */
EMIFCE1L o0 = Ox90000000 1 = 0x10000000 /* Flash/CPLD in 6713 DSK */
EMIFCE2 o0 = OxA0000000 1 = 0x10000000 /* Daughterboard in 6713 DSK */
EMIFCE3 o0 = O0xBO0000OO 1 = 0x10000000 /* Daughterboard in 6713 DSK */
}

Interrupt vectors start at 00000000.

Addresses 00000000-0002FFFF correspond to the lowest 192kB of internal

memory (SRAM) and are labeled “IRAM”.

External memory is mapped to address range 80000000 — 80FFFFFF. This is
16MB and is labeled “EMIFCEQ”.




Linker Command File Example (part 2)

SECTIONS

{

"vectors"
text
.stack
.bss
.cio
.const
.data
.Switch
.sysmem
.far
.args
.ppinfo
.ppdata

vV VvVVVV VV V VYV V VYV

/* COFF sections

.pinit
.cinit

>
>

/* EABI sections

.binit
.init_array
.neardata
.fardata
.rodata
.Cc6xabi.exidx
.Ccbxabi.extab

VvV VvV VvV V V v v

VECS
IRAM
IRAM
IRAM
IRAM
IRAM
IRAM
IRAM
IRAM
IRAM
IRAM
IRAM
IRAM

*/
IRAM
IRAM

*/
IRAM
IRAM
IRAM
IRAM
IRAM
IRAM
IRAM

Both code and data are placed in the

C6713 internal SRAM in this example.
Interrupt vectors are also in SRAM.




vectors.asm

This file contains your interrupt vectors

“.sect” directive at top of file tells linker
where (in memory) to put this code

Each interrupt vector is composed of
exactly 8 assembly language instructions

Example:
MYKL .52 _serialPortRcvISR, BB
MYKH .52 _serialPortRcvISR, BB
B .52 B8
NOP

NOP
NOP
NOP
NOP
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Debugging and Other Useful Features
of the CCS IDE

Breakpoints and stepping through your code
Watch variables

Registers

Plotting arrays of data



Breakpoints: Just Double-Click

)
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2=interrupt void serialPortRcvISR()
{

¥ &

union {Uint32 combo; short channel([2];} temp;

5
6

temp.combo = MCBSP read (DSKé6713 AIC23 DATAHANDLE);
" Note that ri s in temp.channel[0]

// Note that heft channel is in temp.channel[1l]

break point
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MCBSP_write (DSK6713_ AIC23 DATAHANDLE, temp.combo):;

o
}
oyt

Breakpoints: stop code execution at this point to allow state
examination and step-by-step execution.

Also try View->Breakpoints

9 Breakpoints 3 & | % % o W | 5 v =0
Location Name Condition Action

4 [@|*g Spectrum Digital DSK-EVV
[] /2 hello., lined Breakpo... Remain Halted
[] 2 hello., line6 Breakpo... Remain Halted

D stereoloop.c, line 56 (0: Breakpo... Remain Halted




Using Breakpoints

ASM step into

source step over

: ASM step over
source step into
step out

suspend
run/resume

4 7 Spectrum Digital DSK-EVM-eZdsp onboard USB Emulatpr_0/T

= 0x00001E4C (no symbéls are defined for 0x00001E4 ()

restart
. refresh
terminate CPU reset



View Local Variables

View -> Variables

9= Variables 53 | &7 Expressions

Name
4 (= temp unicn <anenymous_U.. {..}
(*)= combo unsigned int 0
4 (™ channel short[2] 0x00001FFC
()= [0] short 0
()= [1] short 0

All local variables should appear automatically. You can’t

see global variables here.

Location

0x00001FFC
0x00001FFC
0x00001FFC
0x00001FFC
0x00001FFE
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View Global Variables

View->Expressions

i ‘ ()= Variables & Expressions £3 | i} Registers

Expression Type Value Address

()= hCodec int 1 0x000023D0
4 (= config struct DSK6713_AL.. {..} 0x000023D4
s (™ regs int[10] 0x000023D4 0x000023D4

()= [0] int 23 0x000023D4
()= [1] int 23 0x000023D8
()= [2] int 0x000023DC
()= [3] int 0x000023E0
()= [4] int 0x000023E4
()= [5] int 0x000023E8
()= [6] int 0x000023EC

Type in any global variable name (or drag a variable name
from the editor)

-
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Some tips:

You can change the number format (rlght click on the

“type”)

You can force data into global/local variables by double
clicking on the “value” and putting a new value in.

Expression
()= hCodec

b (™ config
()= hCodec
op Add new expr

Decimal
Octal
Binary

String

Restore To Preference

al)

Type
int

struct DSK6713_AL.. {..}

int

Value Address

1 0x000023D0

0x000023D4

1 0x000023D0
Ctrl+A

Ctrl+C

Select All

Copy Expressions
Remove

Remove All

Number Format

View Memory

View Memory at Value
Find... Ctrl+F

Add Watch Expression...
Disable

Enable

Edit Watch Expression...
Q-Values

Cast To Type...

Add Global Variables...
Export...




Registers: View->Registers

CCS Debug - Code Compose
ile Edit View Project Tools Run Scripts Window Help

il g ¥~
()= Variables | &' Expressions | ift} Registers ¢33

=3
Name Value Description

4 53 Core Registers
0x0000000F Core
000000001 Core
000000000 Core
034000000 Core
000000000 Core
000000001 Core
000000000 Core
000000001 Core
000000000 Core
0:0000000F Core
000000001 Core
000009048 Core
0xB6F13FBA Core
OxFFE7E794 Core
0xE799EE1C Core
OxES8FFBFFE Core
0x00000F20 Core
0x000000DC Core
000000004 Core
0x00000F98 Core
002030101 Core
0x3C000000 Core
OxFFFFFFFF Core
0x7C000000 Core
000000910 Core
000001140 Core
0x6DDE0270 Core
0xDECBOAOF Core
0:38F98A32 Core
0:35DF9A03 Core
000000200 Core
0x00001FF8 Core
0x00000F39C Core
000000000 Core




Plotting Arrays of Data

[ Graph Properties
Tools -> Graph -> rropety e
Typically “Single Time” R
( yp y g ) gs:DataTy;B)eff S

Index Increment 1
Q_Value 0
Sampling Rate HZ 1

Start Address ©

Display Properties \
Axis Display true

Data Plot Style Line
Display Data Size 200
Grid Style Major Grid A
Magnitude Display Scale Linear d rray Name
Time Display Unit sample

Misc
Use Dc Value For Graph [_] false




Graph Windows: Plotting Arrays of Data

Console | Problems | [ Single Time -0 &3 BHF & vk v ® S K~
1100 ]
1000

900
800
700
600
500
400

Right click for lots of options.
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Profiling Your Code and Making it
More Efficient

How to estimate the
of your code.

How to use the
to produce more efficient code.

Other factors affecting the efficiency
of your code.



How to estimate code execution time
when connected to the DSK

Open the source file you wish to profile

Set two breakpoints for the start/end of the code range you wish to profile

54=-interrupt void serialPortRcvISR()
55 {

union {Uint32 combo; short channel[2]:;} temp;

temp.combo = MCBSP_read (DSK6713_AIC23_ DATAHANDLE) ;

// Note that right channel is in temp.channel[0

// Note that left channel is

in temp.channel[1l]

MCBSP_write (DSK6713 AIC23 DATAHANDLE, temp.combo):
Pe3 )
64

Build it and load .out file to the DSK

Run to the first breakpoint

(or double click the clock to reset the clock to zero)
Run to the second breakpoint

Clock will show raw number of execution cycles between breakpoints.
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Optimizing Compiler

1 v Properties for stereoloo

type filter text Optimization
. Resource
General

4 Build Configuration: |Debug [ Active ] ¥ | | Manage Configurations...

4 (C6000 Compiler

Optimization level (--opt_level, -O)

Include Options Optimize for code size (--opt_for_space, -ms)
Performance Advisor

4 Advanced Options
Advanced Debug Options
Language Options
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Profiling results after compiler optimization

Sl
S et 3

Rebuild and reload the program to the DSK

Use your breakpoint/clock method to profile the
execution time

In this example, we get a 5x-6x improvement with
Level-3 Optimization
Optimization gains can be much larger, e.g. 20x




Limitations of hardware profiling

Variability of results

Profiling is known to be somewhat inaccurate when
connected to real hardware

Breakpoint/clock profiling method may not always work
with compiler-optimized code

For the best results, TI recommends profiling your code in
a cycle accurate simulator:

Change target configuration:
o Connection = Texas Instruments Simulator
o Device = C6713 Device Cycle Accurate Simulator, Little Endian

Need to create a new project for the simulator and copy your
functions/code for profiling to this project without calls to
board-specific functions

Tools -> Profile -> Setup and then Tools-> Profile -> View



Change target configuration for project
to use cycle accurate simulator

Lc| stereoloop.c .£] hello.c ¢ *C6713simulator.coxml &3

Basic

General Setup Advanced Setup
This section describes the general configuration about the target.

Connection Texas Instruments Simulator Target Configura

Board or Device type filter text Save Configurati

C6670 Device Functional Simulator, Big Endian
(6670 Device Functional Simulator, Little Endian
C6678 Device Cycle Approximate Simulator, Big Endiar

Save

Test Connection

To test a connect
configuration file

C6678 Device Cycle Approximate Simulator, Little Endi
(6678 Device Functional Simulator, Big Endian =
(6678 Device Functional Simulator, Little Endian

(6713 Device Cycle Accurate Simulator, Big Endian Test Connectioy

O
O
O
O
O
O
O]

C672x CPU Cycle Accurate Simulator, Little Endian Alternate Comm

C6745 Device Cycle Accurate Simulator, Little Endian  ~
1 \ »

OO




File Edit View Project Tools Run Scripts Window Help
il

Not running on DSK

c_int00() at boot.c:87 0x000018AC (the entry point was reached) All calls to BSL
functions removed

I

// main loop - do nothing but wait for interrupts

myfunc();

3 Code from ISR placed
44 void myfunc() <€

a5 { in a regular function
46 union {Uint32 combo; short channel[2];} temp; called from main()

47 short 1i;

43

49 temp.combo = MCBSP_read(DSK6713_AIC23 DATAHANDLE);
50 // Note that right channel is in temp.channel[@]
51 // Note that left channel is in temp.channel[1]

for (i=0;i<100;i++)
z += x[1]*y[i];

MCBSP_write(DSK6713_AIC23 DATAHANDLE, temp.combo);




Tools -> Profile -> Setup Profile Data Collection

Qg Profile Setup ¢ |

Name: Configuration 1

type filter text Active On:  TMS320C6713

{9- Configuration1 [A |
Activities

| Collect Code Coverage and Exclusive Profile Data

Prpfile all Functions for Total Cycles

Tools -> Profile -> View Function Profile Results

- Profile Setup | B Profile 52
Excl Count Min  Excl Count Max Excl Count Average Excl Count Total Incl Count Min Incl Count Max Incl Count Average Incl Count Total
413860100 4118691

Name Calls
6336 =
7785 7941 7773.83 4112355

1 main() 1 -
3879 3843.37 2033143

2 myfunc() 3849

Inclusive: Includes calls to other functions
Exclusive: Does not include calls to other functions
Results should be more accurate than hardware profiling.
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Other factors affecting code efficiency

Memory

Code location (.text in linker command file)
o internal SRAM memory (fast)

o external SDRAM memory (typically 2-4x slower, depends on cache
configuration)

Data location (.data in linker command file)
o internal SRAM memory (fast)

o external SDRAM memory (slower, depends on datatypes and cache
configuration)

Data types
Slowest execution is double-precision floating point
Fastest execution is fixed point, e.g. short

Example: Stereoloop project,
changing .text and .data
to external SDRAM:
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TMS320C6000 C/C++Data Types

Size

8 bits

g hits

16 bits
16 hits
32 hits
32 hits
40 hits
40 hits
32 hits
32 bits
64 hits
64 hits

Type
char, signed char

unsigned char
short

unsigned short
int, signed int
unsigned int
long, signed long
unsigned long
enum

float

double

long double

Representation
ASCI

ASCI

25 complement
Binary

23 complement
Binary

25 complement
Binary

25 complement
IEEE 32-hit
IEEE 64-hit
IEEE 32-hit

Minimum

-128

0

-32768

0

-2147433648

0

-5497558138885

0

-2147433648
1.175494e-357
2.22507385e-3087
2.22507385e-3087

Range

Maximum

127

255

32767

65535

214733647
4294967295
549755813887
1099511627775
214733647
3.40282346e+38
1.7976931 3e+308
1.7976931 3e+308




Final Remarks

You should have enough information to complete Lab 1
Tutorials on course website

Lab/lecture slides
Reference material noted in slides
Textbooks listed in syllabus

Please
ask questions if you are unsure.



